Microsoft Power Automate flows outtage, Microsoft Power Apps outtage

Incident Report for TALXIS

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 18:21 CET

Monitoring

Updates

Jan 20, 2026, 3:29 PM GMT+1
We've determined that an update to the Power Platform service didn't run as expected, resulting in slow performance, connection failures, and request failures across dependent services. We've confirmed that the service recovered after the aforementioned update completed as expected.
This is the final update for the event.
Posted Jan 20, 2026 - 15:53 CET

Investigating

Some users may be unable to run Microsoft Power Automate flows.

Issue ID: MF1219609
Affected services: Microsoft Power Automate in Microsoft 365
Status: Service degradation
Issue type: Advisory
Start time: Jan 20, 2026, 1:36 PM GMT+1

User impact
Users may be unable to run Microsoft Power Automate flows.

More info
Users may be unable to run flows, use connectors, or perform operations that rely on Power Automate services.

Scope of impact
Impact is specific to some users who are served through the affected infrastructure attempting to run Microsoft Power Automate flows.

and

Some users may be unable to open Microsoft Power Apps

Issue ID: MM1219608
Affected services: Power Apps in Microsoft 365
Status: Service degradation
Issue type: Advisory
Start time: Jan 20, 2026, 1:24 PM GMT+1

User impact
Users may be unable to open Microsoft Power Apps.

More info
Users may be unable to open Power Apps, load data from SharePoint-backed applications, or use connectors that rely on Power Apps services.

Scope of impact
Impact is specific to some users who are served through the affected infrastructure attempting to open Power Apps.


Current status
Jan 20, 2026, 1:38 PM GMT+1
We’re analyzing service telemetry to identify the root cause and develop a remediation plan.
Next update by:
Tuesday, January 20, 2026 at 3:30 PM GMT+1


You can follow the issues here:

https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MM1219608
https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MF1219609

Or in this thread.
Posted Jan 20, 2026 - 14:02 CET
This incident affected: Microsoft (Power Apps).