Azure Front Door and possibly other services down due to DNS misconfiguration

Incident Report for TALXIS

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 13:24 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 22:14 CET

Update

Microsoft has deployed the latest working version, it should be slowly coming back up. You can find the latest info here:

https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 22:14 CET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:34 CET

Investigating

Azure Front Door and possibly other services seem to be down. We are monitoring the issue. You can find the latest info here:

https://x.com/AzureSupport/status/1983569891379835372
https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 17:34 CET
This incident affected: Microsoft (Azure).