LSI21016 - Business Process Flow gets finished even when prerequisites are not satisfied
Incident Report for TALXIS
Resolved
This incident has been resolved.
Posted Sep 05, 2021 - 12:58 CEST
Update
CZ: Příležitosti mohou být uzavírány standartním způsobem. Pokud příležitost bude uzavřená skrze dialog proběhne standartní logika. V případě, že dialog bude opuštěn bez dokončení příležitosti process se uzavře a musí být znova otevřen pro uzavření příležitosti. Dbejte prosím zvýšené pozornosti při klikání na tlačítko "finish". Kontaktujte podporu pro znovuaktivování procesu.

Děkuji.

EN: The Opportunity can be closed using standard practices. If the "finished" button is clicked the Opportunity will immidiately close the process however if you finish the opportunity in the dialog. The Opportunity will close using standart logic. However if the Opportunity will not be closed after clicking the "finish" button for example by leaving the dialog without closing the Opportunity the process has to be openned again. Contact support if you need to reopen the process.

Thank you.
Posted Aug 17, 2021 - 10:34 CEST
Identified
CZ:
Příčina byla identifikována, čekáme na vyjádření Microsoft.

EN:
The issue is identified and we are waiting for Microsoft's response.
Posted Aug 16, 2021 - 22:39 CEST
Investigating
CZ:
Při pokusu o výhru příležitosti může dojít k dokončení procesu, ale příležitost zůstane otevřená. Tento stav se projeví v případě, kdy uživatel nedokončí kroky v dialogu výhry příležitosti.

Příčinou je nefunkční API preventDefault v rámci onPreProcessStatusChange po servisní aktualizaci Power Apps.
https://docs.microsoft.com/en-us/powerapps/developer/model-driven-apps/clientapi/reference/events/onpreprocessstatuschange

Incident je eskalován k Microsoft pod číslem případu #2108160050002453.

EN:
When trying to win an opportunity it may happen that an associated business process is marked as finished but the opportunity stays open. This state can be replicated when a user does not complete the steps in opportunity win dialog.

This is caused by a defect in preventDefault API of onPreProcessStatusChange event handler as result of a Power Apps service update.

Incident is escalated to Microsoft under case #2108160050002453.
Posted Aug 16, 2021 - 22:38 CEST
This incident affected: TALXIS (Apps) and Microsoft (Power Apps).